Информатика, вопрос задал mm13082004 , 2 года назад

Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результате перестановки его последней и предпоследней цифр. ЯЗЫК C++

Ответы на вопрос

Ответил MaxLevs
1

Код

  • #include <iostream>
  • #include <string>
  • #include <functional>
  • std::string switch_first_and_last(std::string N) {
  •    auto L = N.size() - 1;
  •    return N[L] + N.substr(1, L - 1) + N[0];
  • }
  • bool take_correct_number(int &number, const std::function<bool(int)>& Q) {
  •    do {
  •        std::cin >> number;
  •        if (!Q(number)) {
  •            std::cout << "Try again." << std::endl;
  •            continue;
  •        }
  •        break;
  •    } while (true);
  •    return true;
  • }
  • int main() {
  •    int number;
  •    take_correct_number(number, [](int x){return x > 9;});
  •    std::cout << switch_first_and_last(std::to_string(number)) << std::endl;
  • }
Приложения:
Новые вопросы