Программа получает на вход число N.Проанализировать,кратно ли оно 4 или 3.Если кратно 3 вывести фразу «кратно 3».Если кратно 4 вывести фразу «Кратно 4»
Ответы на вопрос
Ответил ingr
0
var
k3, k4 : boolean;
n : integer;
begin
writeln('введите число ');
readln(n);
k3 := n mod 3 = 0;
k4 := n mod 4 = 0;
if k3 and k4 then writeln('кратно 3 и 4')
else if k3 then writeln('кратно 3')
else if k4 then writeln('кратно 4')
else writeln('хрень а не число');
end.
прога так же сообщает еси число кратно 3 и 4 либо не крато ни тому ни другому.
Новые вопросы
Другие предметы,
2 года назад
Русский язык,
2 года назад
Алгебра,
7 лет назад
Биология,
9 лет назад
Математика,
9 лет назад