Информатика, вопрос задал МишкиРулят , 8 лет назад

программа получает на вход целые числа, не равные 0. Количество введенных чисел неизвестно, последовательность чисел заканчивается 0. Введенные числа по модулю не превышают 30000. Программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?

Ответы на вопрос

Ответил Аноним
0
Var A,Max,Min:integer;
Begin
ReadLn(A);
Max:=A;
Min:=A;
While A<>0 do
   Begin
   ReadLn(A);
   if A>Max then Max:=A;
   if A<Min then Min:=A;
   End;
WriteLn(Max/Min > 2)
End.
Новые вопросы