Информатика, вопрос задал 675max , 2 года назад

программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные
Входная строка содержит одно натуральное число.

Выходные данные
Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Ответы на вопрос

Ответил falcon22
0
var
s:string;
i:longint;
t:boolean;

begin
read(s);
t:=false;

for i:=1 to length(s)-1 do
 if s[i]=s[i+1] then t:=true;

if t then writeln('YES') else writeln('NO');
end.
Новые вопросы