Программа на с++
Напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a дают в остатке b , а при делении на c дают в остатке d .
Входные данные
Первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. Вторая строка содержит натуральные числа c и d, также разделённые пробелом. Гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c.
Выходные данные
Программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a дают в остатке b, а при делении на c дают в остатке d . Если таких чисел нет, программа должна вывести число -1.
Ответы на вопрос
Ответил xerex21
0
#include <iostream>
using namespace std;
int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)
if (i % a ==b && i % c == d)
{
cout<<i<<' ';
o=1;
}
if (o==0)
cout<<-1;
}
using namespace std;
int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)
if (i % a ==b && i % c == d)
{
cout<<i<<' ';
o=1;
}
if (o==0)
cout<<-1;
}
Новые вопросы