Информатика, вопрос задал skokov2001 , 8 лет назад

Программа на c++

Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ] .

Входные данные
Входная строка содержит два натуральных числа – значения a и b . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести квадраты чисел в диапазоне [ a , b ] и показать способ вычисления. Например, если ввести 4 и 5, программа должна вывести

4*4=16

5*5=25

Ответы на вопрос

Ответил clinteastwood2
0
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    int a, b;
    cin >> a >> b;
    for (int i=a; i<=b; i++) {
      cout << i << "*" << i << " = " << pow(i, 2) << endl;
    }
    return 0;
}
Новые вопросы