Другие предметы, вопрос задал malika7713191929 , 1 год назад

программа c++;Дана строка.Определить долю в процентах арабских цифр в ней.

Ответы на вопрос

Ответил lmaobb
1

Ответ:

#include <iostream>

#include <string>

using namespace std;

int main() {

string s;

cout << "Введите строку: ";

getline(cin, s);

int len = s.length();

int cnt_digits = 0;

for (int i = 0; i < len; i++) {

if (isdigit(s[i])) {

cnt_digits++;

}

}

double percent = (double)cnt_digits / (double)len * 100;

cout << "Доля арабских цифр в строке: " << percent << "%" << endl;

return 0;

}

Данная программа считывает строку, затем проходится по каждому символу и проверяет, является ли он цифрой. Если символ является цифрой, увеличиваем счетчик цифр. После этого вычисляем долю арабских цифр в строке в процентах и выводим результат на экран.!


lmaobb: можно лучший ответ, кнопка не сразу появится
malika7713191929: можешь ещё составить программу
malika7713191929: помочь
lmaobb: какая
malika7713191929: ПРОГРАММА C++. Опишите структуру PRICE (название товара, цена, название магазина). Введите с клавиатуры данные в массив, состоящий из семи элементов типа PRICE. Выведите на экран всю информацию о товарах, продающихся в магазине, название которого введено с клавиатуры. Если такого магазина нет, то программа должна выдать соответствующее сообщение на экран.
lmaobb: вопрос создай
malika7713191929: пожалуйста очень нужно,заранее спасибо))
malika7713191929: я создала вопрос
Новые вопросы