Информатика, вопрос задал race17 , 10 лет назад

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество.

Программа 5. Пользователь вводит число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Приложения:

Ответы на вопрос

Ответил max705
0

4 подойдет?:

 

Program P1;
Uses Crt;
Var a, s : Real;

Begin
ClrScr;
Write('Введи угол: ');
Readln(a);
s := sqr(sin(a)) + sqr(cos(a));

If s = 1 then
Writeln('sin^2(a) + cos^2(a) = ', s)
Else
Writeln('Выполнена неверная операция, вселенная будет уничтожена!');

Readln;
End.

Новые вопросы