Информатика, вопрос задал nurislom100 , 9 лет назад

program sro3_2;
var
A,B,C:array [1..20] of integer;
n,k,l,i:integer;
begin

writeln('|||Входные данные задачи|||');
write('Введите количество элементов:');
readln(n);
writeln('Массив А:');
for i:=1 to n do;
read(A[i]);
k:=1;
l:=1;
for i:=1 to N do
if i mod 2=0 then begin k:=k+1;
B[k]:=A[i];

end
else l:=l+1;
C[l]:=A[i];

writeln('Массив B с четными элементами:',b[k]);
read(b[k]);
writeln('Массив C с нечетными элементами:',c[l]);
read(c[l]);
writeln;
writeln;
end.
НЕ МОГУ НАЙТИ ОШИБКУ ИСПРАВЬТЕ ПЛИИИЗЗЗЗ!!!!!

Ответы на вопрос

Ответил SuperCode
0
var
A,B,C:array [1..20] of integer;
n,k,l,i:integer;
begin 
writeln('|||Входные данные задачи|||');
write('Введите количество элементов:');
readln(n);
writeln('Массив А:');
for i:=1 to n do
Begin
read(A[i]); 
if a[i] mod 2=0 then
 begin k:=k+1;
B[k]:=A[i];
end
else
l:=l+1;
C[l]:=A[i];
End;
writeln('Массив B с четными элементами:');
for i:=1 to k do
write(b[i],'  ');
writeln;
writeln('Массив C с нечетными элементами:');
for i:=1 to l do
write(c[i],'  ');
end.
Ответил nurislom100
0
ответ не вышел
Новые вопросы