Информатика, вопрос задал JuceZ , 2 года назад

Привет, помоги плиз)




Напишите программу, которая вычисляет следующее значение. По теореме Пифагора, в прямоугольном треугольнике соотношение сторон C2=A2+B2. Если А=3, В=2, Каково значение С? Pascal.

Ответы на вопрос

Ответил nastikots
1

Ответ:

program z1;

var a,b,c: real;

Begin

write ('a = ');

readln(a);

write ('b = ');

readln(b);

c:=sqrt(a*a+sqr(b));

write ('c = ',c:0:3)

End.

Объяснение:

a = 3

b = 2

c ≈ 3.606

sqrt (x) - корень квадратный из числа х

sqr (x) - возведение числа х в квадрат

:0:3 - форматированный вывод, второе число (3) указывает количество знаков после запятой

Новые вопросы