Привет!Очень срочно!!!Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: S=pi *R^2
Ответы на вопрос
Ответил HRAshton
0
procedure MinMax(var min, max: real);
var
a: real;
begin
if (min > max) then
begin
a := min;
min := max;
max := a;
end;
end;
var
r1, r2: real;
begin
readln(r1, r2);
r1 := pi * sqr(r1);
r2 := pi * sqr(r2);
MinMax(r1, r2);
writeln('S = ', r2 - r1);
end.
var
a: real;
begin
if (min > max) then
begin
a := min;
min := max;
max := a;
end;
end;
var
r1, r2: real;
begin
readln(r1, r2);
r1 := pi * sqr(r1);
r2 := pi * sqr(r2);
MinMax(r1, r2);
writeln('S = ', r2 - r1);
end.
Приложения:

Ответил Аноним
0
Там описка в блок-схеме S1-S2, а не R1-S2
Ответил chuvashevaanas
0
Спасибо большое!!!
Новые вопросы