Информатика, вопрос задал noopee , 2 года назад

Придумать задачу для Pascal ABC, которая содержит не менее 3 условий (разветвляющиеся вычислительные процессы) и написать программу к ней

Ответы на вопрос

Ответил kordark
1
Задача: Пользователем вводится целое число. Если оно чётное и больше 20, то отнять 5, если меньше 20, прибавить 5. Если нечетное и отрицательное, то поменять знак числа, если положительное, то умножить на 2. Вывести полученное число на экран.

kordark: var a;
kordark: var a;
begin
readln(a);
if a mod 2=0 then
if a<20 then
a:=a+5
else
a:=a-5
else
if a<0 then
a:=a*(-1)
else
a:=a*2;
writeln(a);
end.
Новые вопросы