Превратить все значения массива С(9) стоящие после наименьшего значения массива в ноль. Напишите программу на С++.
Я написала программу прикреплённую ниже, но после введения значений массива ничего не происходит и не выходит. Помогите пожалуйста
Приложения:

restIess:
этот код запустится разве?
Ответы на вопрос
Ответил restIess
2
#include <iostream>
using namespace std;
signed main() {
setlocale(LC_ALL, "Rus");
int C[9], min, i_min = 0;
for (int i = 0;i<9;i++){
cin >> C[i];
}
min = C[0];
for (int i = 1; i < 9; i++) {
if (C[i] < min) {
min = C[i];
i_min = i;
}
}
for (int i = i_min+1; i < 9; i++)//если надо и минимум обнулять, то нужно убрать +1
C[i] = 0;
cout << endl;
cout << "Изменённый массив: ";
for (int i = 0; i < 9; i++)
cout << C[i] << " ";
}
Новые вопросы
Русский язык,
2 года назад
Қазақ тiлi,
2 года назад
Математика,
2 года назад
Психология,
2 года назад
Алгебра,
8 лет назад