Информатика, вопрос задал Procrastination , 2 года назад

пожалуйста, выручайте, нужно написать программу на С/С++

Приложения:

Аноним: Что за термин такой "арифметическая последовательность"? Арифметическая прогрессия?
Аноним: В русском языке есть математические термины "числовая последовательность" и "арифметическая прогрессия". Так что у кого-то явные проблемы с терминологией.
Procrastination: действительно написано коряво, скорее всего имеется ввиду арифметическая прогрессия
Аноним: Попробуем решить))

Ответы на вопрос

Ответил Andrey05
0
Готово....................
Приложения:
Ответил Аноним
0
#include <iostream>
#include <cstdlib>

using namespace std;

int main() {
    int i,n;
    cout<<"Vvedite n: ";
    cin>>n;
    int a[n];
    for (i=0; i<n; i++){
        cout<<"Vvedite "<<i+1<<"-e chislo massiva: ";
        cin>>a[i];
    }
    int d=a[1]-a[0];
    i=1;
    int f=0;
    while (i<n-1 && f==0)
       { if (a[i+1]!=(a[i]+d)) f=1; i++; }
    if (f==0) cout<<"Proggressia\n"; else cout<<"Ne progressia\n";
    cin>>n; //чтобы окно не закрывалось
    return 0;
}

Новые вопросы