Информатика, вопрос задал RouvaSloth , 9 лет назад

Пожалуйста, срочно помогите написать программу в Pascal ABC для вычисления среднего гармонического значения элементов массива Х (N), кратных двум. При этом даны ограничения, что xi>0, N<30. N должно выбираться через генератор случайных чисел Random и Randomize.

Ответы на вопрос

Ответил archery
0
var
    a: array[1..100] of integer;
    i, n: integer;
    harmonic: real;
    k: integer;

begin
    Randomize;
    n := random(20) + 10;
    
    for i := 1 to n do
    begin
        a[i] := random(50);
        write(a[i], ' ');
    end;
    writeln();
    
    harmonic := 1;
    k := 0;
    for i := 1 to n do
    begin
        if a[i] mod 2 = 0 then {фильтр}
        begin
            harmonic := harmonic + 1 / a[i];
            k := k + 1;
        end;
    end;
    writeln('harmonic mean = ', k / harmonic);
end.
Новые вопросы