Информатика, вопрос задал Killme666v , 2 года назад

ПОЖАЛУЙСТА, СРОЧНО! ДАЮ 100Б
НУЖНО РЕШЕНИЕ НА ПИТОНЕ ЧЕРЕЗ ЦИКЛ for
Входные данные
Вводятся целые числа a и b. Гарантируется, что a не превосходит b

Выходные данные
Выведите (через пробел) все четные числа от a до b (включительно).

Примеры
входные данные
2
5
выходные данные
2 4

Ответы на вопрос

Ответил restIess
3

a,b = int(input()), int(input())

for i in range(a,b+1):

   if i % 2 == 0:

       print(i,end=" ")

       


Phlxyd: можно оптимизировать, если сразу в цикле идти по четным числам
Phlxyd: (a+1)//2, b, 2
restIess: Можно, но тогда надо чутка исправить, если введем 1 и любое число, то 1 + 1 = 2, 2 // 2 = 1, и пойдет он печатать нечетные числа
Новые вопросы