Пожалуйста составьте программу в паскале
Дан массив, состоящий из 100 целых чисел. Выведите все числа, которые встречаются в этом массиве:
а) несколько раз;
б) только по одному разу.
Ответы на вопрос
Ответил Redov
0
Первое задание, программа задает массив, сортирует его, затем сравнивает элемент с последующем
uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
var t: integer;
begin
t := x;
x := y;
y := t
end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]=a[i+1] then
begin
writeln(a[i]);
writeln(a[i+1]);
end;
end.
Второе задание. Программа также сортирует и сравнивает элементы
uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
var t: integer;
begin
t := x;
x := y;
y := t
end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]<>a[i+1] then
begin
writeln(a[i]);
end;
end.
uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
var t: integer;
begin
t := x;
x := y;
y := t
end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]=a[i+1] then
begin
writeln(a[i]);
writeln(a[i+1]);
end;
end.
Второе задание. Программа также сортирует и сравнивает элементы
uses crt;
var
a:array[1..100] of integer;
i,j:integer;
procedure swap(var x,y: integer);
var t: integer;
begin
t := x;
x := y;
y := t
end;
begin
for i:=1 to 100 do a[i]:=random(100);
for j:=1 to 99 do
for i:=1 to 100-j do if a[i] > a[i+1] then swap(a[i],a[i+1]);
for i:=1 to 99 do if a[i]<>a[i+1] then
begin
writeln(a[i]);
end;
end.
Новые вопросы