Информатика, вопрос задал dimakurikjaja , 2 года назад

ПОЖАЛУЙСТА PYTHON !Составьте программу, которая бы просила пользователя ввести натуральное число от 10 до 20. Результатом выполнения должны быть все трицифрови числа, кратные введенному числу (то есть, делятся нацело на введенное число)


kuritskiy3: Поднимай до 20 сделаю

Ответы на вопрос

Ответил bilanovfatim
1

Ответ:

val = int(input('Введите число от 10 до 20: '))

a = []

for i in range(100, 1000):

 if i%val == 0:

   a.append(i)

print(*a)

Приложения:

dimakurikjaja: Смотри, я ввела в первой строке 16(где надо было ввести число от 10до 20) и мне выбило что я что-то не правильно сделала , что не так?
bilanovfatim: странно, все работает, возможно что-то не так со средой разработки в которой пишешь
bilanovfatim: прикрепил скрин, все работает
dimakurikjaja: Мне всё полностью переписыватькак есть? Типо ничего не вводить?
dimakurikjaja: Спасибо огромное:)
Новые вопросы