Информатика, вопрос задал jab123 , 1 год назад

Пожалуйста помогите составить программу
с++ вычисляющую:

Приложения:

imnof: а вместо многоточия что?

Ответы на вопрос

Ответил fivaproldzh1337
0

#include <iostream>

#include <string>

#include <math.h>

using namespace std;

int main()

{

   int n;

   cout << "Enter n: ";

   cin >> n;

 

   float ans = 0;

   for (int i = 2*n; i != 0; i -= 2)

       {

           ans = sqrt(ans);

           ans += i;

       }

   ans = sqrt(ans);

   cout << ans;

}


fivaproldzh1337: Вообще я глупость сделал. "ans = sqrt(ans);" и " ans += i;" (14 и 15 строки) можно поменять местами и убрать "ans = sqrt(ans);" (17 строка) после выхода из цикла. Так красивее.
Новые вопросы