Информатика, вопрос задал karakozov20021Egovan , 8 лет назад

Пожалуйста помогите составить программу по вычислению НОК и НОД на Pascal

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function GCD_LCM(a,b:integer):(integer,integer);
begin
  var c:=a*b;
  while b>0 do (a,b):=(b,a mod b); // a - НОД
  Result:=(a,c div a)
end;

begin
  var (a,b):=ReadInteger2('Введите два натуральных числа:');
  var (НОД,НОК):=GCD_LCM(a,b);
  Writeln('НОД = ',НОД, ', НОК = ',НОК)
end.

Пример
Введите два натуральных числа: 13624 320
НОД = 8, НОК = 544960
Новые вопросы