Пожалуйста помогите с решением!!!!
1.Написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «Нужно продолжить работу?», и пользователь отвечаетда/нет. Программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше.
2. Дан массив из 10-ти чётных натуральных чисел – от 2 до 20. А) Найдите сумму элементов массива.Б) Найдите минимальный элемент массива.
3. Дан массив из 15 подряд идущих натуральных чисел, начиная с 50.А) Найдите произведение элементов массива.Б) Найдите максимальный элемент массива.
Ответы на вопрос
Ответил ubunt
0
второе
var A: array [1..10] of integer;
I,S: integer;
min:=a[1];
beginfor I:=1 to 10 do
begin
a[i]:=random(10);
S:=S+A[I];
write(a[i],' ');
end;
for i:=2 to 10 do
begin
if min>a[i] then
min:=a[i];
end;
writeln;
writeln ('сумма=',S);
writeln ('минимальное=',min);
end.
var A: array [1..10] of integer;
I,S: integer;
min:=a[1];
beginfor I:=1 to 10 do
begin
a[i]:=random(10);
S:=S+A[I];
write(a[i],' ');
end;
for i:=2 to 10 do
begin
if min>a[i] then
min:=a[i];
end;
writeln;
writeln ('сумма=',S);
writeln ('минимальное=',min);
end.
Ответил tva31
0
каким образом получилось это решение?
Ответил tva31
0
да адрес есть
Ответил ubunt
0
зайди к себе на ящик и отправь письмо, туда скопируй то, что я написал
Ответил tva31
0
спасибо, я так и сделаю. А остальные задания не получаются?
Ответил ubunt
0
5 баллов за 3 задачи это очень мало, создавай еще вопросы с этими задачами - чем смогу помогу
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Геометрия,
10 лет назад
Математика,
10 лет назад
Математика,
10 лет назад