Пожалуйста помогите с Паскалем
Назовем число палиндромом, если оно не меняется при перестановке его цифр в обратном порядке. Напишите программу, которая по заданному числу K выводит количество натуральных палиндромов, не превосходящих K.
Входные данные
Задано единственное число K (1<=K=<100000).
Выходные данные
Необходимо вывести количество натуральных палиндромов, не превосходящих K.
пс Функции не проходили, надо как то без них
nemolkl:
(1K100000). Понимать как 1>K>100000
Ответы на вопрос
Ответил nemolkl
2
{L-левая половинка числа, R - правая}
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.
Новые вопросы
Английский язык,
1 год назад
Русский язык,
1 год назад
Английский язык,
2 года назад
Обществознание,
2 года назад
Литература,
7 лет назад
Математика,
7 лет назад