Информатика, вопрос задал Бантикова , 9 лет назад

Пожалуйста,помогите решитьn задачи Pascal.Помогите решить хотя бы те ,которые сможете♥♥.СРОЧНО НУЖНО НА ЗАВТРА.
1)Заполните массив их 20 элементов целыми числами из интервала [-10;19],используя генератор случайных величин.
2)Заполнить массив из 10 элементов целыми числами из интервала -20-29 числа вводятся с клавиатуры.
3)Используя программу к задаче 1,напишите программу,которая подсчитывает количество положительных элементов массива.
4)Используя программу к задаче 1,напишите программу ,которая заменяет все отрицательные элементы массива на 0.
5)Используя программу к задаче 1,напишите программу,которая находит сумму всех положительных элементов массива.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.0, сборка 1128
begin
  var a:=ArrRandom(20,-10,19);
  a.Println(','); // 1
  var b:=ReadArrInteger('Введите 10 целых чисел',10); // 2
  Writeln('Количество положительных элементов ',
    a.Where(x->x>0).Count); // 3
  for var i:=0 to 19 do
    if a[i]<0 then a[i]:=0;
  Writeln('Массив А после замены отрицательных'); a.Println(','); //4
  Writeln('Сумма положительных элементов ',
    a.Where(x->x>0).Sum) // 5
end.

Тестовое решение:
14,8,9,-5,6,3,3,-10,-8,18,7,13,2,17,-1,0,4,-3,8,-8
Введите 10 целых чисел -5 0 13 -7 -14 11 8 19 -3 -1
Количество положительных элементов 13
Массив А после замены отрицательных
14,8,9,0,6,3,3,0,0,18,7,13,2,17,0,0,4,0,8,0
Сумма положительных элементов 112
Ответил Бантикова
0
Благодарю!
Ответил Аноним
0
Пожалуйста
Ответил SanGreen74
0
Задача №1

var a:array [1..20] of integer;     
i:integer;
begin 
randomize;   
for i:=1 to 20 do begin   
a[i]:=random(19-(-10)+1)+-10;     
write (a[i],' ');           
end;
end.

Задача №2

var a:array [1..20] of integer; 
i:integer; 
begin 
writeln('Введите числа в интервале [-20;29]'); 
for i:=1 to 10 do read(a[i]); 
for i:=1 to 10 do 
if (a[i]>-29) and (a[i]<20) then write(a[i],' '); 
end.

Задача №3

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+1; 
end; 
writeln('Количество положительных элементов массива = ', sum); 
end.

Задача №4

var a:array [1..20] of integer; 
i:integer; 
begin 
randomize; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
if a[i]<0 then a[i]:=0; 
write (a[i],' '); 
end; 
end.

Задача №5

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+a[i]; 
end; 
writeln('Сумма положительных элементов массива = ', sum); 
end.
Ответил Бантикова
0
Большое спасибо за помощь!
Ответил Аноним
0
Да. Отличное подтверждение, что в школе учат как НЕ НАДО писать программы.
Новые вопросы