Информатика, вопрос задал max55518 , 8 лет назад

ПОЖАЛУЙСТА ПОМОГИТЕ РЕШИТЬ ЭТУ ЗАДАЧУ . (Написать программу на языке C++) . В некотором государстве в обращении применяются купюры достоинством 1, 5, 10, 50, 100, 500 и 1000 единиц. Сколькими способами можно разменять купюру достоинством 1000 единиц? Найти количество всех простых чисел в диапазоне от 2 до 100 000.

Ответы на вопрос

Ответил clinteastwood2
0
"Найти количество всех простых чисел в диапазоне от 2 до 100 000", - решение через Решето Эратосфена.
#include <iostream>
#include <vector>
using namespace std; 
 
int main()
{
    unsigned a = 0, b = 0;
    cin >> a >> b;
    vector<char> v(b + 1, '1');
     for (unsigned i = 3; i < v.size(); i += 2) {
        for (unsigned j = i + i; j < v.size(); j += i) {
            vec[j] = '0';
        }
    }
 
    if (a == 2) {
        cout << 2 << " ";
    }
   
    a += !(a&1);

    for (unsigned i = a; i < v.size(); i+=2){
        if (vec[i] == '1') {
            cout << i << " ";
        }
    }
    return 0;
}
Ответил max55518
0
Огромное спасибо тебе за твою помощь !!!
Новые вопросы