Информатика, вопрос задал givas , 10 лет назад

ПОЖАЛУЙСТА ПОМОГИТЕ ОЧЕНЬ НАДО 


Написать программу, которая "задумывает" число в диапазоне от 1 до 10 и предлагает пользователю угадать число за 5 попыток.

Ответы на вопрос

Ответил Аноним
0
(С подсказками, не надо - удали)
var r,ch,z: integer;
begin
Randomize;
r:=random(10)+1;
z:=5;
repeat
write('Отгадайте число от 1 до 10. У вас ',z,' попыток :');
readln(ch);
z:=z-1;
if z>0 then
begin
If ch<r then Writeln('Неправильно! Загаданное число больше.')
else If ch>r then Writeln('Неправильно! Загаданное число меньше.')
else writeln('Вы угадали!');
end
else Writeln('Попытки кончились!');
until (z=0)or(ch=r);
End.


Новые вопросы