Пожалуйста помогите написать программу и составить блоксхему !
Определить среди 3 введенных чисел сумму отрицательных и положительных.Если больше сумма положительных,то найти минимум из этих 3 чисел , а иначе найти максимум.
Ответы на вопрос
Ответил nikolac
0
uses crt;
var sump,sumn,i:integer;
a:array[1..3] of integer;
begin
for i:=1 to 3 do
begin
read(a[i]);
if a[i]>=0 then
sump:=sump+a[i]
else
sumn:=sumn+a[i];
end;
if sump>=sumn then
writeln(min(min(a[1],a[2]),min(a[2],a[3])))
else
writeln(max(max(a[1],a[2]),max(a[2],a[3])));
end.
var sump,sumn,i:integer;
a:array[1..3] of integer;
begin
for i:=1 to 3 do
begin
read(a[i]);
if a[i]>=0 then
sump:=sump+a[i]
else
sumn:=sumn+a[i];
end;
if sump>=sumn then
writeln(min(min(a[1],a[2]),min(a[2],a[3])))
else
writeln(max(max(a[1],a[2]),max(a[2],a[3])));
end.
Ответил Adequate
0
Вообщем, забудь :)
Ответил Adequate
0
М... заморила твоя задача однако
Program asd;
USES crt;
var
A:array [1..5] of integer;
min,max,min2,o,p:real;
i,n:integer;
Procedure max1;
begin
for i:=1 to 5 do
if A[i]>0 then
if min<A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
Procedure min1;
begin
for i:=1 to 5 do
if A[i]<0 then
if min>A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
BEGIN
clrscr;
For i:=1 to 5 do
begin
A[i]:=random(9)-5;
Write(' ',A[i]);
end;
Writeln;
//Otrizanie
For i:=1 to 5 do
if A[i]<0 then o:=o+A[i];
Writeln('Summa otrizatelnyx elementov: ',o);
//Polowitelnye
For i:=1 to 5 do
if A[i]>0 then p:=p+A[i];
Writeln('Summa polowitelnyx elementov: ',p);
if p<o then max1
else min1;
END.
Program asd;
USES crt;
var
A:array [1..5] of integer;
min,max,min2,o,p:real;
i,n:integer;
Procedure max1;
begin
for i:=1 to 5 do
if A[i]>0 then
if min<A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
Procedure min1;
begin
for i:=1 to 5 do
if A[i]<0 then
if min>A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
BEGIN
clrscr;
For i:=1 to 5 do
begin
A[i]:=random(9)-5;
Write(' ',A[i]);
end;
Writeln;
//Otrizanie
For i:=1 to 5 do
if A[i]<0 then o:=o+A[i];
Writeln('Summa otrizatelnyx elementov: ',o);
//Polowitelnye
For i:=1 to 5 do
if A[i]>0 then p:=p+A[i];
Writeln('Summa polowitelnyx elementov: ',p);
if p<o then max1
else min1;
END.
Ответил Adequate
0
Вообщем скажу как есть.
Программа пускает 5 чисел разных. Считает общую сумму отрицательных и положительных чисел. Далее, находит максимальный положительный элемент и максимальный отрицательный элемент и при условии p<o подключает соответственную процедуру для отрицания и положительного числа. Но так нельзя! Ребята, исправьте мой код у меня голова не варит или не могу понять суть...
Программа пускает 5 чисел разных. Считает общую сумму отрицательных и положительных чисел. Далее, находит максимальный положительный элемент и максимальный отрицательный элемент и при условии p<o подключает соответственную процедуру для отрицания и положительного числа. Но так нельзя! Ребята, исправьте мой код у меня голова не варит или не могу понять суть...
Ответил Adequate
0
Может сделать дополнительный массив под это, который сначала заполнить всеми отрицательными элементами, которые вышли, А потом среди них уже просто искать минимальный... не знаю :)
Новые вопросы
Литература,
2 года назад
Математика,
2 года назад
Обществознание,
10 лет назад
Математика,
10 лет назад