пожалуйста помогите!!!
написать программу для подсчета количества счастливых билетов выданных и оставшихся если ваш билет под № n
Ответы на вопрос
Ответил A1dar
0
function isLucky(a: integer): boolean;
var s: string;
begin
str(a, s);
while length(s) < 6 do s := '0' + s;
isLucky := ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
end;
var
sTicket: string;
iTicket, i, err, sum: longint;
begin
write('Введите Ваш номер билета: ');
read(sTicket);
val(sTicket, iTicket, err);
for i := 1 to iTicket do
if isLucky(i) then inc(sum);
writeln('Выдано ', sum, ' счастливых билетов');
writeln('Осталось выдать ', 55251 - sum, ' счастливых билетов')
end.
var s: string;
begin
str(a, s);
while length(s) < 6 do s := '0' + s;
isLucky := ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
end;
var
sTicket: string;
iTicket, i, err, sum: longint;
begin
write('Введите Ваш номер билета: ');
read(sTicket);
val(sTicket, iTicket, err);
for i := 1 to iTicket do
if isLucky(i) then inc(sum);
writeln('Выдано ', sum, ' счастливых билетов');
writeln('Осталось выдать ', 55251 - sum, ' счастливых билетов')
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Английский язык,
2 года назад
Обществознание,
9 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад