Пожалуйста помогите, надо сдавать работу !
Написать программу на языке С++
В заданном одномерном массиве поменять местами соседние элементы, стоящие на чётных местах, с элементами, стоящими на нечётных.
Ответы на вопрос
Ответил MaxLevs
0
#include <iostream>
#include <cstdlib>
using namespace std;
int main(){
int n = 10;
int arr[n];
for(int i = 0; i < n; ++i){
arr[i] = rand() % 300 - 150;
cout << arr[i] << " ";
}
cout << endl;
/*Начало важной части*/
for(int i = 0; i < n/2; ++i){
int buff = arr[2*i];
arr[2*i] = arr[2*i+1];
arr[2*i+1] = buff;
}
/*Конец важной части*/
cout << "Result: ";
for(int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
system("pause");
return 0;
}
#include <cstdlib>
using namespace std;
int main(){
int n = 10;
int arr[n];
for(int i = 0; i < n; ++i){
arr[i] = rand() % 300 - 150;
cout << arr[i] << " ";
}
cout << endl;
/*Начало важной части*/
for(int i = 0; i < n/2; ++i){
int buff = arr[2*i];
arr[2*i] = arr[2*i+1];
arr[2*i+1] = buff;
}
/*Конец важной части*/
cout << "Result: ";
for(int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
system("pause");
return 0;
}
Ответил timofee1999
0
всё работает, спасибо
Ответил timofee1999
0
а нельзя значения самому ввести?
Ответил MaxLevs
0
Можно. Но моя задача, дать тебе код, который меняет элементы местами.
Ответил MaxLevs
0
Все остальное - мешура, чтобы показать, как работает код.
Новые вопросы
Математика,
2 года назад
Английский язык,
2 года назад
Химия,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад