ПОЖАЛУЙСТА, ОЧЕНЬ СРОЧНО!!!!
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи- вается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы на вопрос
Ответил gvk20
0
Ответ:
program z;
uses crt;
var
s,x: longint;
begin
s:=0;
read(x);
while (x<>0) do begin
if (x mod 10=4) and (x div 6=0) then
s:=s+x;
end;
write(s);
end.
Объяснение:
Ответил мелани21
0
Можешь ещё помочь, пожалуйста?
Даны положительные вещественные числа a и b (a > b). На отрезке длины a размещено максимально возможное количество отрезков длины b (без наложений). Не используя операции умножения и деления, найти длину незанятой части отрезка a.
Входные данные: Ввести два вещественных числа a и b (1<=a,b<=1010).
Выходные данные: Вывести длину незанятой части отрезка a c точностью до 2 цифр в дробной части.
Даны положительные вещественные числа a и b (a > b). На отрезке длины a размещено максимально возможное количество отрезков длины b (без наложений). Не используя операции умножения и деления, найти длину незанятой части отрезка a.
Входные данные: Ввести два вещественных числа a и b (1<=a,b<=1010).
Выходные данные: Вывести длину незанятой части отрезка a c точностью до 2 цифр в дробной части.
Новые вопросы
Русский язык,
2 года назад
Другие предметы,
2 года назад
Химия,
7 лет назад
История,
7 лет назад
Литература,
9 лет назад