Информатика, вопрос задал student1213 , 8 лет назад

Пожалуйста! Напишите программу в паскале, которая высчитывает средний бал оценок (нужно чтобы в программу можно было вводить хоть сколько оценок).

Ответы на вопрос

Ответил figyshkin2
0
program p1;
var 
i,j,s:integer; 
r: double; 
a:array [1..9999] of integer;
begin
writeln('Запишите кол-во оценок');
read(j);
for i:=1 to j do 
begin 
writeln('Введите оценку #', i); 
read (a[i]); 
end;
for i:=1 to j do 
begin 
s:=a[i]+s; 
end; 
writeln('сумма оценок = ', s);
r:=s/j;
writeln('Средний бал = ',r);
end.
Новые вопросы