Пожалуйста,напишите программу в паскаль.
Дан текстовый файл содержащий строки и столбцы цифр . Найдите количество строк и общее количество элементов.
В файле написано
1 2 3
7 8 9 11 12
3 2
1 2 3 4
Maotay:
Элементы : 14
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadLines('Text.txt').ToArray;
var k:=s.Count;
var n:=s.JoinIntoString.Matches('\b\d+\b').Count;
Writeln('Строк: ',k,', числовых элементов: ',n)
end.
Пример
Строк: 4, числовых элементов: 14
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadLines('Text.txt').ToArray;
var k:=s.Count;
var n:=s.JoinIntoString.Matches('\b\d+\b').Count;
Writeln('Строк: ',k,', числовых элементов: ',n)
end.
Пример
Строк: 4, числовых элементов: 14
Приложения:
Новые вопросы