Информатика, вопрос задал AlenaShalygina , 2 года назад

Пожалуйста!) напишите программу которая вычисляет сколько раз введенное с клавиатуры число встречается в массиве ( в pascal)

Ответы на вопрос

Ответил Hasl1337
5

const n = 10;
var
  a: array[1..n] of integer;
  i, x, count: integer;
begin
  readln(x);
  for i := 1 to n do begin
    a[i] := random(100);
    write(a[i], ' ');
    if(a[i] = x) then inc(count);
  end;
  writeln;
  writeln('Число ', x, ' встречается в массиве ', count, ' раз');
end.

Новые вопросы