Информатика, вопрос задал sarkisyanlada54 , 1 год назад

ПОЖАЛУЙСТА!!!
Напишите программу, которая определяет среднюю температуру за сентябрь. Температура задается случайными числами в диапазоне от 5 до 15 градусов


musicwave15: А можно мне сразу список всех задач, я тебе быстренько решу, и ты не будешь тратить много много балов)
sarkisyanlada54: Эта задача не на C++ нужна
musicwave15: На каком языке?

Ответы на вопрос

Ответил musicwave15
0

#include <iostream>

#include <cstdlib>

#include <math.h>

#include <time.h>

using namespace std;

int main()

{

system("chcp 1251 > null");

srand(time(0));

int n = 30;

int z = 0;

double sum = 0;

double sr = 0;

cout << "Температура: \n";

for(int i = 0; i<n; i++){

   z = rand()%11+5;

   cout << "\n" << z;

   sum = sum + z;

}

sr = sum/n;

cout << "\n\nСредняя температура за сентябрь: " << sr;

}

Оценивать так же можно кнопочкой "Лучший ответ" :З

Новые вопросы