Пожалуйста, напишите программу для того, чтобы в целом натуральном числе n поменять местами первую и последнюю цифру, с помощью цикла While в Pascal ABC.
Дам за него 15 баллов. Пожалуйста, помогите!
Ответы на вопрос
Ответил kage1998
0
program chik;
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.
var n,a,b,s,q,k:integer;
begin
readln(n);
q:=n mod 10;
while n>0 do
begin
b:=n mod 10;
n:=n div 10;
s:=s*10+b;
end;
n:=q;
s:=s div 10;
while s>10 do
begin
k:=s mod 10;
s:=s div 10;
n:=n*10+k;
end;
n:=n*10+b;
writeln(n);
end.
Ответил Натка3
0
Я нашла покороче:
Program Izmenenie;
var n,d,p:integer;
begin
write('n = ');
ReadLn(N);
p:=n;
d:=1; while n div (d*10)>0 do
d:=d*10;
n:=n mod 10*d+n mod d div 10*10+n div d;
WriteLn('Èçìåíåííîå ÷èñëî : ', n);
end.
Program Izmenenie;
var n,d,p:integer;
begin
write('n = ');
ReadLn(N);
p:=n;
d:=1; while n div (d*10)>0 do
d:=d*10;
n:=n mod 10*d+n mod d div 10*10+n div d;
WriteLn('Èçìåíåííîå ÷èñëî : ', n);
end.
Новые вопросы