Пожалуйста, напишите программу для паскаля: для нахождения делителей числа n и их суммы с помощью цикла while
Натка3:
Можете, если не хватит времени добавлять в комменты
Ответы на вопрос
Ответил Александрий
1
program s;
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.
var d, n, s: integer;
begin
readln(n);
s:=0;
d:=1;
while(d<=n) do
begin
if(n mod d = 0) then
begin
s:=s+d;
writeln(d);
end;
d:=d+1;
end;
writeln(s);
end.
Приложения:
begin
readln(n);
s:=0;
i:=1;
while(i<=n) do
begin
if(n mod i = 0) then
begin
s:=s+i;
write(i,' ');
end;
i:=i+1;
end;
writeln('Сумма делителей:',s);
end.
Новые вопросы
Немецкий язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Биология,
7 лет назад