Информатика, вопрос задал Аноним , 2 года назад

Пожалуйста напишите программу.Даю 50 балов

Приложения:

Ответы на вопрос

Ответил nastikots
2

Ответ:

program z1;

var a:real;

begin

readln(a);

write (trunc(frac(a)*100) mod 10)

end.

Объяснение:

Берём дробную часть, умножаем на 100, отбрасываем дробную часть и получаем последнюю цифру.

Предположим а = 100.123

Берём дробную часть: frac (a) = 0,123

Умножаем на 100: frac (a) * 100 = 12,3

Отбрасываем дробную часть: trunc (frac (a) * 100) = 12

Получаем последнюю цифру: trunc (frac (a) * 100) mod 10 = 2

По этапам:

program z1;

var a:real;

b:integer;

begin

readln(a);

a:=frac(a);

a:=a*100;

b:=trunc(a);

b:=b mod 10;

write (b)

end.


Аноним: Получаеься
Аноним: Настя?
Аноним: Спасибо большое
nastikots: Пожалуйста )
nastikots: Да, Настя )
Аноним: Насть можешь разложить по нескольким этапам а не все в одной строке
Аноним: ???
Аноним: Я сам разложил но выдаёт ошибку
nastikots: Поправила ответ. Операция mod выполняется только с целыми числами, поэтому добавила переменную.
Аноним: Спасибо))
Новые вопросы