Пожалуйста изобразите только блок-схему, программу не надо .
Даны целое число m и матрица размера m x m. Составьте блок-схему алгоритма получения и вывода вектора B и напишите программу на языке Турбо Паскаль, элементы которой bi равны количеству элементов i строки данной матрицы, которые больше заданного числа k по абсолютной величине.
Ответы на вопрос
Блок-схема алгоритма может выглядеть следующим образом:[Ввод] Ввод целого числа m и матрицы размера m x m
[Ввод] Ввод числа k
[Инициализация] Создание вектора B размера m
[Цикл] Цикл по строкам матрицы
[Цикл] Цикл по элементам строки
[Условие] Если элемент матрицы больше k по абсолютной величине, увеличить bi на 1
[Вывод] Вывод вектора B
Программа на языке Турбо Паскаль может выглядеть следующим образом
var
m, k: integer;
A: array[1..100, 1..100] of integer;
B: array[1..100] of integer;
i, j: integer;
begin
write('Введите размер матрицы: ');
readln(m);
write('Введите матрицу:');
for i := 1 to m do
for j := 1 to m do
read(A[i, j]);
write('Введите число k: ');
readln(k);
for i := 1 to m do
begin
B[i] := 0;
for j := 1 to m do
if abs(A[i, j]) > k then
B[i] := B[i] + 1;
end;
writeln('Вектор B:');
for i := 1 to m do
write(B[i], ' ');
writeln;
end.