Информатика, вопрос задал kripton4545 , 9 лет назад

Пож помогите кто может заранее спс..Составить программу, запрашивающую у пользователя дату в кратком формате дд.мм.гг (например: 15.10.2012), и отображающую эту дату в полном формате (например: 15 октября 2012 года).

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var cm:array[1..12] of string:=
    ('января','февраля','марта','апреля','мая','июня',
    'июля','августа','сентября','октября','ноября','декабря');
  var dmy:=ReadlnString('Дата в формате ДД.ММ.ГГГГ:').ToWords('.');
  Writeln(dmy[0]+' '+cm[dmy[1].ToInteger]+' '+dmy[2]+' года')
end.

Тестовое решение
Дата в формате ДД.ММ.ГГГГ: 13.07.2016
13 июля 2016 года
Новые вопросы