Информатика, вопрос задал ikadenisova , 10 лет назад

Построить блок-схему и написать программу 
1. Вычислить S=1+2+3+4+…+N 
2. Для данного N составить алгоритм вычисления факториала N!=1*2*3*…*N

Ответы на вопрос

Ответил ff923
0
1.
 program z;
var n,i:integer; s:real;
begin
writeln('Введите число n'); readln(n);
for i:=1 to n do
begin
s:= (n*(n+1))/2; end;
writeln(s); 
end.
2. program z2;
var s,i,n:integer;
begin
writeln('Введите число n '); readln (n);
s:=1;

for i:=1 to n do s:=s*i;

write(s); end.

Ответил ikadenisova
0
спасибо
Новые вопросы