Информатика, вопрос задал radmira8971 , 2 года назад

Последовательность
Напишите программу, которая выводит N первых чисел возрастающей последовательности двузначных чисел, не содержащих одинаковых цифр.

Ввод: N - количество отображаемых чисел.
Выход: возрастающая последовательность двузначных чисел, не содержащих одинаковых цифр.
Input
12
Output
10, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 23
input
2
output
10, 12


ppgem374: Язык?

Ответы на вопрос

Ответил ppgem374
0

count = int(input())

i = 10

while count > 0:

   if i % 10 != i // 10:

       print(i, end=', ')

       count -= 1

   i += 1

Ответил nazikmuz
0

Відповідь:

C++ code:

#include <iostream>

bool check(int input){

return input % 10 == input / 10;

}

int main() {

int number;

std::cin >> number;

for(int start = 0, num = 10; start <= number; start++, num++){

 if(!check(num)){

  std::cout << num << " ";

 }

}

return 0;

}

Новые вопросы