Помогити плииииз:3Даю 40 балов
Напишите программу, которая в последовательности целых чисел находит сумму чётных чисел в диапазоне
от 5 до 25. Программа получает на вход целые числа, количество введённых чисел неизвестно,
последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в
последовательность).
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
var a,sum: integer;
begin
sum:=0;
readln(a);
while a<>0 do begin
if (a>=5) and (a<=25) and (a mod 2=0) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
var a,sum: integer;
begin
sum:=0;
readln(a);
while a<>0 do begin
if (a>=5) and (a<=25) and (a mod 2=0) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
Ответил maska031
0
можешь еще решить задачек которые я выложу?Тоже столько же балов:3
Ответил maska031
0
Дам 98 балов:3https://znanija.com/task/31445165
Ответил fdefas
0
Программа и результат её выполнения на скриншотах.
Приложения:


Ответил csharp
0
Просто на будущее - есть цикл с постусловием (чтобы не писать два раза readln):
repeat {блок операторов} until {условие};
repeat {блок операторов} until {условие};
Ответил maska031
0
Спасибо) Просто у нас все строго. И если я буду так писать то получу 2)
Ответил maska031
0
Подумают что списала
Ответил csharp
0
У Вас есть железный аргумент - самообразование)
Ответил maska031
0
Ну у меня школа с углубленным изучением информатики. Думаю не прокатит)
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
7 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад