Информатика, вопрос задал wolf532rytu , 8 лет назад

помогитееееееееее написать программу в паскале:Заполнить двумерный массив N*N случайными числами из интервала [-10,10] и найти сумму элементов меньших элемента стоящего в К-ом столбце и L-ой строке. ПОЖАЛУЙСТА ПОМОГИТЕЕЕЕЕЕЕЕЕЕ

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк (столбцов) в массиве:');
  Writeln('*** Исходный массив [',n,',',n,'] ***');
  var a:=MatrRandom(n,n,-10,10);
  a.Println(4); Writeln(5*a.ColCount*'-');
  var k,l:integer;
  Write('Введите L,K: '); Read(l,k);
  var lim:=a[l-1,k-1];
  var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum;
  Writeln('Искомая сумма равна ',s)
end.

Пример
Количество строк (столбцов) в массиве: 6
*** Исходный массив [6,6] ***
  -4  -8  -7  -3  -6  -4
   2  -9   1   9  -6   6
  -9  -2  -8  -3  -1  -4
  -1  -9  -3  -7   3  -3
   5   9  -6   8  -1 -10
  -1  -1  -5  -8  -9   4
------------------------------
Введите L,K: 2 3
Искомая сумма равна -138
Новые вопросы