помогитееее Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var s:=ReadInteger('n=').ToString;
if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
begin
var s:=ReadInteger('n=').ToString;
if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
Ответил Lhjg
0
такое еще не проходили(
не понимаю
не понимаю
Ответил Аноним
0
А это Ваши проблемы! Откуда нам всем знатб, что Вы проходили, а что нет? Надо писать в условии задания ограничения на методы решения.
Ответил Lhjg
0
откуда мне знать какого вы возраста
Ответил Аноним
0
А возраст тут не при чем. Вам такой же ответ может дать и старшеклассник.
Новые вопросы
Другие предметы,
2 года назад
Математика,
9 лет назад
География,
9 лет назад
Математика,
9 лет назад