ПОМОГИТЕЕЕЕ!!!!
Написать программу на языке С (массивы)
В классе 32 ученика, рост которых от 147 до 168 см. Написать программу, которая определила бы номер самого высокого ученика и его рост
пожалуйста пожалуйста!!!!!!
Ответы на вопрос
Ответ:
//Братишка, я тебе С++ принёс
#include <iostream>
/*
#include<cstdlib>
#include<ctime>
#include<cmath>*/
using namespace std;
/*
void fill(int arr[32]){
srand(time(NULL));
for(int i = 0;i<32;i++){
arr[i] = rand()%22 + 147;
}
}*/
int main()
{
int students[32];
//fill(students);
for(int i = 0;i<32;i++){
cin>>students[i];
}
int max_index = students[0];
for(int i = 0;i<32;i++){
if(students[i]>max_index){
max_index=i;
}
//Не обязательно
else{
continue;
}
}
cout<<"Рост:"<<students[max_index]<<endl;
cout<<"Номер:"<<max_index+1;
return 0;
}
Объяснение:
Код в комментариях нужен для автоматизации заполнения(чтобы не придумывать 32 числа)