ПОМОГИТЕ СРОЧНЯК!!!Составить программу, которая подсчитывает в имеющимся файле количество чисел и выводит ответ на экран и в файл output.txt
Аноним:
Какой тип данных в файле, как он организован?
Ответы на вопрос
Ответил Аноним
1
var
f:Text;
n,k:integer;
begin
Assign(f,'input.txt');
Reset(f);
n:=0;
while not Eof(f) do begin Read(f,n); Inc(k) end;
Close(f);
Assign(f,'output.txt');
Rewrite(f);
Writeln(f,k); Writeln(k);
Close(f)
end.
f:Text;
n,k:integer;
begin
Assign(f,'input.txt');
Reset(f);
n:=0;
while not Eof(f) do begin Read(f,n); Inc(k) end;
Close(f);
Assign(f,'output.txt');
Rewrite(f);
Writeln(f,k); Writeln(k);
Close(f)
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
2 года назад
Химия,
2 года назад
Математика,
7 лет назад