Помогите срочнооо♥♥♥♥
Дан массив из 20
произвольных
элементов, каждый из
которых не больше 100.
Найдите максимальный
элемент кратный 6.
Ответы на вопрос
Ответил SAOD
0
const k=6;
var a:array [1..20] of integer;
i,max:integer;
Begin
max:=-1;
for i:=1 to 20 do begin
a[i]:=random(100); (или for i:=1 to 20 do writeln(a[i]); - здесь ручной ввод)
if a[i] mod k = 0 then begin
if a[i]>max then max:=a[i]; end;
end;
writeln(max);
end.
var a:array [1..20] of integer;
i,max:integer;
Begin
max:=-1;
for i:=1 to 20 do begin
a[i]:=random(100); (или for i:=1 to 20 do writeln(a[i]); - здесь ручной ввод)
if a[i] mod k = 0 then begin
if a[i]>max then max:=a[i]; end;
end;
writeln(max);
end.
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Физика,
8 лет назад
Обществознание,
8 лет назад
Математика,
9 лет назад