Информатика, вопрос задал jsJastin , 2 года назад

Помогите срочно!!!!!!язык паскаль. задача 1: Написать программу для поиска наименьшего элемента в массиве, заданного случайным образом и состоящим из 12 элементов.
задача 2: Написать программу для поиска в массиве, заданного случайным образом и состоящим из 20 элементов, элемента, равного 65​


jsJastin: паскаль
jsJastin: а вы можете мне помочь?
BlackHole3003: обязательно случайным образом?
jsJastin: да
jsJastin: привет можешь помочь ещё с одним номером пожалуйста
BlackHole3003: смотря с каким
jsJastin: Задача: Найти произведение элементов массива от 30 до 70. Массив задан случайным образом и состоит из 20 элементов.
(т.е умножаются те элементы, которые больше 30, но меньше 70)
jsJastin: язык паскаль
BlackHole3003: program test2;

var i: integer;

var poisk: int64;

a: array[1..20] of integer;

begin
poisk:= 1;
for i:=1 to 20 do

begin

a[i]:= random(100);
if (a[i] > 30) and (a[i] < 70) then
poisk := poisk * a[i];

end;
if poisk = 1 then
writeln('нет элементов массива от 30 до 70')
else
writeln('произведение элементов массива от 30 до 70= ', poisk)


end.
jsJastin: спасибо

Ответы на вопрос

Ответил BlackHole3003
2

program test1;

var r, minim, i: integer;

a: array[1..12] of integer;

begin

 for i:=1 to 12 do

 begin

   a[i]:= random(100);

 end;

 minim := a[1];

 for i:=1 to 12 do

 begin

   if minim > a[i] then

     minim:= a[i];

 end;

 writeln('минимальное значение=', minim);

end.

program test2;

var i: integer;

var poisk: string;

a: array[1..20] of integer;

begin

 for i:=1 to 20 do

 begin

   a[i]:= random(100);

 end;

 for i:=1 to 20 do

 begin

   if a[i] = 65 then

     poisk:=poisk + i;

 end;

 if poisk = '' then

   writeln('нет элементов массива со значением 65')

 else writeln('элемент(ы) массива со значением 65 ',poisk)

end.


jsJastin: спасибо тебе огромное дай бог здаоовья
jsJastin: здоровье *
Новые вопросы