Информатика, вопрос задал Аноним , 10 лет назад

ПОМОГИТЕ!!! Срочно!! 
Составьте программу на языке программирования ( Паскаль ). И построить алгоритм на алгоритмическом языке. Можно решить одну из задач.
1) Найти площадь прямоугольного треугольника и его периметр по известным катетам a и b.
2) Найти площадь равнобедренной трапеции с основаниями a и b и боковой стороной c.

Ответы на вопрос

Ответил archery
0
var a,b:real;
Begin
  readln(a,b);
  writeln('S = ', a*b*0.5);
  writeln('P = ', a+b+sqrt(a*a+b*b));
End.

var a,b,c:real;
Begin
  readln(a,b,c);
  writeln('S = ', c*(a+b)*0.5);
End.


Ответил murtik
0
во второй задаче не прямоуг а равнобедреная трапеция
Ответил archery
0
да а разве формула площади не верная?
Ответил murtik
0
1)
var a, b, c, area, perimeter:real;
BEGIN    
Writeln('Введите катет a=');    
Readln(a);    
Writeln('Введите 
 катет b=');    
Readln(b);    
area:=a*b/2;
c:=sqrt (sqr(a)+sqr(b));
perimeter:=a+b+c;
Writeln('Площадь =', area);
Writeln('Периметр a=', perimeter);  
End.
Новые вопросы