Информатика, вопрос задал avozud82pawlo12345 , 1 год назад

ПОМОГИТЕ СРОЧНО
Напишите свою программу, которая предложит пользователю ввести число. Выведите на экран тип числа. Используйте функции ввода-вывода и переменные.
2.
Используя библиотеку turtle нарисуйте два круга разных диаметров. Задайте стиль, цвет фона, цвет линий, скорость и размер линий.
3
Используя цикл for и библиотеку turtle нарисуйте 10 прямоугольников.
4
Напишите программу, которая бы выполняла перевод единиц измерения. Метры в сантиметры.
5
Напишите программу, которая будет выводить только четные числа в интервале от 100 до 150. Используйте цикл while для решения данной задачи.


avozud82pawlo12345: ПАЙТОН ВСЕ ЭТО

Ответы на вопрос

Ответил pisarkovoleksij
3

Ответ:

1) Программа для определения типа числа:

num = input("Введите число: ")

if num.isdigit():

    num = int(num)

    if num > 0:

        print("Положительное число")

    elif num < 0:

        print("Отрицательное число")

    else:

        print("Ноль")

else:

    print("Вы ввели не число")

2) Программа для рисования двух кругов:

import turtle

# Создаем экран

screen = turtle.Screen()

# Задаем цвет фона

screen.bgcolor("white")

# Создаем черепашку

t = turtle.Turtle()

# Задаем цвет линий

t.pencolor("black")

# Задаем скорость

t.speed(1)

# Задаем размер линий

t.pensize(3)

# Рисуем первый круг

t.fillcolor("red")

t.begin_fill()

t.circle(50)

t.end_fill()

# Рисуем второй круг

t.penup()

t.goto(100, 0)

t.pendown()

t.fillcolor("blue")

t.begin_fill()

t.circle(25)

t.end_fill()

# Закрываем экран при клике на него

screen.exitonclick()

3) Программа для рисования 10 прямоугольников:

import turtle

# Создаем экран

screen = turtle.Screen()

# Задаем цвет фона

screen.bgcolor("white")

# Создаем черепашку

t = turtle.Turtle()

# Задаем цвет линий

t.pencolor("black")

# Задаем скорость

t.speed(1)

# Задаем размер линий

t.pensize(3)

# Рисуем 10 прямоугольников

for i in range(10):

    t.penup()

    t.goto(i*20, i*20)

    t.pendown()

    t.forward(50)

    t.right(90)

    t.forward(25)

    t.right(90)

    t.forward(50)

    t.right(90)

    t.forward(25)

    t.right(90)

# Закрываем экран при клике на него

screen.exitonclick()

4) Программа для перевода метров в сантиметры:

meters = float(input("Введите количество метров: "))

centimeters = meters * 100

print(meters, "метров =", centimeters, "сантиметров")

5) Программа для вывода четных чисел в интервале от 100 до 150:

num = 100

while num <= 150:

    if num % 2 == 0:

        print(num)

    num += 1

Новые вопросы