Информатика, вопрос задал katme14 , 7 лет назад

Помогите, срочно!!!
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 4 и НЕ оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число - сумму чисел, кратных 4 и НЕ оканчивающихся на 8.

Ответы на вопрос

Ответил anywaythanks
0

На фото программа написанная на языке C++.

Программа в текстовом варианте:

#include <iostream>

using namespace std;

int main() {

  int n,a,sum = 0;

  cout << "Введите кол-во чисел:" << endl;

  cin >> n;

  cout << endl <<"Введите сами числа:" << endl;

  for(;n > 0;--n){//Это всё тот же цикл с счётчиком, однако переменная здесь не задаётся

      cin >> a;

      if(a%4 == 0 && a%10 != 8 )

          sum+=a;

  }

  cout << "Сумма: " << sum;

  return 0;

}

Приложения:
Новые вопросы